What’s Vulnerable › Vulnerabilities
CVE-2022-28321
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-19 · updated 2026-10-14
- Weakness: CWE-287
Description
The Linux-PAM package before 1.5.2-6.1 for openSUSE Tumbleweed allows authentication bypass for SSH logins. The pam_access.so module doesn't correctly restrict login if a user tries to connect from an IP address that is not resolvable via DNS. In such conditions, a user with denied access to a machine can still get access. NOTE: the relevance of this issue is largely limited to openSUSE Tumbleweed and openSUSE Factory; it does not affect Linux-PAM upstream.
Affected products
- Linux-PAM: before 1.5.2-6.1 — fixed in 1.5.2-6.1
How to fix
Upgrade to a fixed version: Linux-PAM 1.5.2-6.1. Check the vendor advisory for mitigations.
References
- http://download.opensuse.org/source/distribution/openSUSE-current/repo/oss/src/
- https://bugzilla.suse.com/show_bug.cgi?id=1197654
- https://www.suse.com/security/cve/CVE-2022-28321.html
- http://download.opensuse.org/source/distribution/openSUSE-current/repo/oss/src/
- https://bugzilla.suse.com/show_bug.cgi?id=1197654
- https://www.suse.com/security/cve/CVE-2022-28321.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2022-28321 or the next vulnerability affects your stack