What’s Vulnerable › Vulnerabilities

CVE-2022-28352

Description

WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.

Affected products

How to fix

Upgrade to a fixed version: weechat 3.4.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-28352 or the next vulnerability affects your stack