What’s Vulnerable › Vulnerabilities
CVE-2022-28366
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
Description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Affected products
- nahsra antisamy: before 1.6.6 — fixed in 1.6.6
- Cyberneko Html Project Cyberneko Html: through 1.9.22
- net.sourceforge.htmlunit:htmlunit: before 2.27 — fixed in 2.27
How to fix
Upgrade to a fixed version: nahsra antisamy 1.6.6; net.sourceforge.htmlunit:htmlunit 2.27. Check the vendor advisory for mitigations.
References
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6
- https://search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit
- https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6
- https://search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit
- https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/
Get alerted when CVE-2022-28366 or the next vulnerability affects your stack