What’s Vulnerable › Vulnerabilities
CVE-2022-28367
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
OWASP AntiSamy before 1.6.6 allows XSS via HTML tag smuggling on STYLE content with crafted input. The output serializer does not properly encode the supposed Cascading Style Sheets (CSS) content.
Affected products
- nahsra antisamy: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: nahsra antisamy 1.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/nahsra/antisamy/commit/0199e7e194dba5e7d7197703f43ebe22401e61ae
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6
- https://github.com/nahsra/antisamy/commit/0199e7e194dba5e7d7197703f43ebe22401e61ae
- https://github.com/nahsra/antisamy/releases/tag/v1.6.6
Get alerted when CVE-2022-28367 or the next vulnerability affects your stack