What’s Vulnerable › Vulnerabilities
CVE-2022-2845: Improper Validation of Specified Quantity in Input in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-17 · updated 2026-10-09
- Weakness: CWE-1284
Description
Improper Validation of Specified Quantity in Input in GitHub repository vim/vim prior to 9.0.0218.
Affected products
- Fedoraproject Fedora: 35, 37
- vim/vim: before 9.0.0218 — fixed in 9.0.0218
How to fix
Upgrade to a fixed version: vim/vim 9.0.0218. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/e98c88c44c308edaea5994b8ad4363e65030968c
- https://huntr.dev/bounties/3e1d31ac-1cfd-4a9f-bc5c-213376b69445
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/e98c88c44c308edaea5994b8ad4363e65030968c
- https://huntr.dev/bounties/3e1d31ac-1cfd-4a9f-bc5c-213376b69445
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XWOJOA7PZZAMBI5GFTL6PWHXMWSDLUXL/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2845 or the next vulnerability affects your stack