What’s Vulnerable › Vulnerabilities
CVE-2022-28463
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-08 · updated 2026-06-17
- Weakness: CWE-120
Description
ImageMagick 7.1.0-27 is vulnerable to Buffer Overflow.
Affected products
- Debian Linux: 9.0, 10.0
- ImageMagick: from 6.9.4-0 before 6.9.12-44; from 7.0.1-0 before 7.1.0-29 — fixed in 6.9.12-44, 7.1.0-29
How to fix
Upgrade to a fixed version: ImageMagick 6.9.12-44, 7.1.0-29. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/commit/ca3654ebf7a439dc736f56f083c9aa98e4464b7f
- https://github.com/ImageMagick/ImageMagick/issues/4988
- https://github.com/ImageMagick/ImageMagick6/commit/e6ea5876e0228165ee3abc6e959aa174cee06680
- https://lists.debian.org/debian-lts-announce/2022/05/msg00018.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00020.html
- https://github.com/ImageMagick/ImageMagick/commit/ca3654ebf7a439dc736f56f083c9aa98e4464b7f
- https://github.com/ImageMagick/ImageMagick/issues/4988
- https://github.com/ImageMagick/ImageMagick6/commit/e6ea5876e0228165ee3abc6e959aa174cee06680
- https://lists.debian.org/debian-lts-announce/2022/05/msg00018.html
- https://lists.debian.org/debian-lts-announce/2023/05/msg00020.html
Get alerted when CVE-2022-28463 or the next vulnerability affects your stack