What’s Vulnerable › Vulnerabilities
CVE-2022-28508
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-04 · updated 2026-06-17
- Weakness: CWE-79
Description
An XSS issue was discovered in browser_search_plugin.php in MantisBT before 2.25.2. Unescaped output of the return parameter allows an attacker to inject code into a hidden input field.
Affected products
- mantisbt: before 2.25.2 — fixed in 2.25.2
How to fix
Upgrade to a fixed version: mantisbt 2.25.2. Check the vendor advisory for mitigations.
References
- https://github.com/YavuzSahbaz/CVE-2022-28508/blob/main/MantisBT%202.25.2%20XSS%20vulnurability
- https://mantisbt.org/
- https://sourceforge.net/projects/mantisbt/
- https://github.com/YavuzSahbaz/CVE-2022-28508/blob/main/MantisBT%202.25.2%20XSS%20vulnurability
- https://mantisbt.org/
- https://sourceforge.net/projects/mantisbt/
Get alerted when CVE-2022-28508 or the next vulnerability affects your stack