What’s Vulnerable › Vulnerabilities
CVE-2022-28618
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection security vulnerability has been identified in HPE Nimble Storage Hybrid Flash Arrays, HPE Nimble Storage All Flash Arrays and HPE Nimble Storage Secondary Flash Arrays that could allow an attacker to execute arbitrary commands on a Nimble appliance. HPE has made the following software updates to resolve the vulnerability in HPE Nimble Storage: 5.0.10.100 or later, 5.2.1.0 or later, 6.0.0.100 or later.
Affected products
- HPE Nimbleos: before 5.0.10.100; from 5.1.0.0 before 5.2.1.500; from 5.3.0.0 before 6.0.0.100 — fixed in 5.0.10.100, 5.2.1.500, 6.0.0.100
How to fix
Upgrade to a fixed version: HPE Nimbleos 5.0.10.100, 5.2.1.500, 6.0.0.100. Check the vendor advisory for mitigations.
References
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04276en_us
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst04276en_us
Get alerted when CVE-2022-28618 or the next vulnerability affects your stack