What’s Vulnerable › Vulnerabilities
CVE-2022-2864
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-28 · updated 2026-06-17
Description
The demon image annotation plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 4.7. This is due to missing nonce validation in the ~/includes/settings.php file. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- demonisblack demon image annotation: before 4.8 — fixed in 4.8
How to fix
Upgrade to a fixed version: demonisblack demon image annotation 4.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/demon-image-annotation/trunk/includes/settings.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2772352%40demon-image-annotation&new=2772352%40demon-image-annotation&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2864
- https://plugins.trac.wordpress.org/browser/demon-image-annotation/trunk/includes/settings.php
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2772352%40demon-image-annotation&new=2772352%40demon-image-annotation&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories/#CVE-2022-2864
Get alerted when CVE-2022-2864 or the next vulnerability affects your stack