What’s Vulnerable › Vulnerabilities
CVE-2022-2867
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-17 · updated 2026-06-17
- Weakness: CWE-191
Description
libtiff's tiffcrop utility has a uint32_t underflow that can lead to out of bounds read and write. An attacker who supplies a crafted file to tiffcrop (likely via tricking a user to run tiffcrop on it with certain parameters) could cause a crash or in some cases, further exploitation.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36
- libtiff: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: libtiff 4.4.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2118847
- https://lists.debian.org/debian-lts-announce/2023/01/msg00018.html
- https://www.debian.org/security/2023/dsa-5333
- https://bugzilla.redhat.com/show_bug.cgi?id=2118847
- https://lists.debian.org/debian-lts-announce/2023/01/msg00018.html
- https://www.debian.org/security/2023/dsa-5333
Get alerted when CVE-2022-2867 or the next vulnerability affects your stack