What’s Vulnerable › Vulnerabilities
CVE-2022-2868
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-17 · updated 2026-06-17
- Weakness: CWE-20
Description
libtiff's tiffcrop utility has a improper input validation flaw that can lead to out of bounds read and ultimately cause a crash if an attacker is able to supply a crafted file to tiffcrop.
Affected products
- Debian Linux: 10.0, 11.0
- Fedoraproject Fedora: 35, 36
- libtiff: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: libtiff 4.4.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2118863
- https://lists.debian.org/debian-lts-announce/2023/01/msg00018.html
- https://www.debian.org/security/2023/dsa-5333
- https://bugzilla.redhat.com/show_bug.cgi?id=2118863
- https://lists.debian.org/debian-lts-announce/2023/01/msg00018.html
- https://www.debian.org/security/2023/dsa-5333
Get alerted when CVE-2022-2868 or the next vulnerability affects your stack