What’s Vulnerable › Vulnerabilities
CVE-2022-28684
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-03 · updated 2026-06-17
- Weakness: CWE-502
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of DevExpress. Authentication is required to exploit this vulnerability. The specific flaw exists within the SafeBinaryFormatter library. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the service account. Was ZDI-CAN-16710.
Affected products
- DevExpress: from 18.1.0 before 18.1.18; from 18.2.0 before 18.2.17; from 19.1.0 before 19.1.15; from 19.2.0 before 19.2.14; from 20.1.0 before 20.1.15; from 20.2.0 before 20.2.11 — fixed in 18.1.18, 18.2.17, 19.1.15, 19.2.14, 20.1.15, 20.2.11
How to fix
Upgrade to a fixed version: DevExpress 18.1.18, 18.2.17, 19.1.15, 19.2.14. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-22-872/
- https://www.zerodayinitiative.com/advisories/ZDI-22-872/
Get alerted when CVE-2022-28684 or the next vulnerability affects your stack