What’s Vulnerable › Vulnerabilities
CVE-2022-28685
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-29 · updated 2026-06-17
- Weakness: CWE-502
Description
This vulnerability allows remote attackers to execute arbitrary code on affected installations of AVEVA Edge 2020 SP2 Patch 0(4201.2111.1802.0000). User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of APP files. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-17212.
Affected products
- AVEVA Edge: before 2020.2.00.40 — fixed in 2020.2.00.40
How to fix
Upgrade to a fixed version: AVEVA Edge 2020.2.00.40. Check the vendor advisory for mitigations.
References
- https://www.aveva.com/content/dam/aveva/documents/support/cyber-security-updates/SecurityBulletin_AVEVA-2022-005.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-22-1124/
- https://www.aveva.com/content/dam/aveva/documents/support/cyber-security-updates/SecurityBulletin_AVEVA-2022-005.pdf
- https://www.zerodayinitiative.com/advisories/ZDI-22-1124/
Get alerted when CVE-2022-28685 or the next vulnerability affects your stack