What’s Vulnerable › Vulnerabilities

CVE-2022-28716

Description

On 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all versions of 12.1.x 11.6.x, a DOM-based cross-site scripting (XSS) vulnerability exists in an undisclosed page of the BIG-IP AFM, CGNAT, and PEM Configuration utility that allows an attacker to execute JavaScript in the context of the currently logged-in user. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated

Affected products

How to fix

Upgrade to a fixed version: BIG-IP 13.1.5, 14.1.4.6, 15.1.5.1, 16.1.2.2; F5 Big-Ip Carrier-Grade Nat 13.1.5, 14.1.4.6, 15.1.5.1, 16.1.2.2; F5 Networks, Inc. BIG-IP (PEM) 13.1.5, 14.1.4.6, 15.1.5.1, 16.1.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-28716 or the next vulnerability affects your stack