What’s Vulnerable › Vulnerabilities
CVE-2022-28736: There's a use-after-free vulnerability in grub_cmd_chainloader() function
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-20 · updated 2026-06-17
- Weakness: CWE-416
Description
There's a use-after-free vulnerability in grub_cmd_chainloader() function; The chainloader command is used to boot up operating systems that doesn't support multiboot and do not have direct support from GRUB2. When executing chainloader more than once a use-after-free vulnerability is triggered. If an attacker can control the GRUB2's memory allocation pattern sensitive data may be exposed and arbitrary code execution can be achieved.
Affected products
- grub2: from 2.00 before 2.06-3 — fixed in 2.06-3
How to fix
Upgrade to a fixed version: grub2 2.06-3. Check the vendor advisory for mitigations.
References
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28736
- https://security.netapp.com/advisory/ntap-20230825-0002/
- https://www.openwall.com/lists/oss-security/2022/06/07/5
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-28736
- https://security.netapp.com/advisory/ntap-20230825-0002/
- https://www.openwall.com/lists/oss-security/2022/06/07/5
Get alerted when CVE-2022-28736 or the next vulnerability affects your stack