What’s Vulnerable › Vulnerabilities

CVE-2022-28739

Description

There is a buffer over-read in Ruby before 2.6.10, 2.7.x before 2.7.6, 3.x before 3.0.4, and 3.1.x before 3.1.2. It occurs in String-to-Float conversion, including Kernel#Float and String#to_f.

Affected products

How to fix

Upgrade to a fixed version: Apple macOS 11.7.1, 12.6.1; Ruby 2.6.10, 2.7.6, 3.0.4, 3.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-28739 or the next vulnerability affects your stack