What’s Vulnerable › Vulnerabilities

CVE-2022-28805

Description

singlevar in lparser.c in Lua from (including) 5.4.0 up to (excluding) 5.4.4 lacks a certain luaK_exp2anyregup call, leading to a heap-based buffer over-read that might affect a system that compiles untrusted Lua code.

Affected products

How to fix

Upgrade to a fixed version: Lua 5.4.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-28805 or the next vulnerability affects your stack