What’s Vulnerable › Vulnerabilities
CVE-2022-2882
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-28 · updated 2026-06-17
- Weakness: CWE-668
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.6 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1. A malicious maintainer could exfiltrate a GitHub integration's access token by modifying the integration URL such that authenticated requests are sent to an attacker controlled server.
Affected products
- GitLab: from 12.6.0 before 15.2.5; from 15.3 before 15.3.4; from 15.4 before 15.4.1 — fixed in 15.2.5, 15.3.4, 15.4.1
How to fix
Upgrade to a fixed version: GitLab 15.2.5, 15.3.4, 15.4.1. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2882.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/371082
- https://hackerone.com/reports/1656722
- https://gitlab.com/gitlab-org/cves/-/blob/master/2022/CVE-2022-2882.json
- https://gitlab.com/gitlab-org/gitlab/-/issues/371082
- https://hackerone.com/reports/1656722
- https://gitlab.com/gitlab-org/gitlab/-/issues/371082
Get alerted when CVE-2022-2882 or the next vulnerability affects your stack