What’s Vulnerable › Vulnerabilities
CVE-2022-28820: Adobe Consulting Services Reflected Cross-Site Scripting Arbitrary Code Execution
- Severity: medium (CVSS 4.3 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-21 · updated 2026-06-17
- Weakness: CWE-79
Description
ACS Commons version 5.1.x (and earlier) suffers from a Reflected Cross-site Scripting (XSS) vulnerability in /apps/acs-commons/content/page-compare.html endpoint via the a and b GET parameters. User input submitted via these parameters is not validated or sanitised. An attacker must provide a link to someone with access to AEM Author, and could potentially exploit this vulnerability to inject malicious JavaScript content into vulnerable form fields and execute it within the context of the victim's browser. The exploitation of this issue requires user interaction in order to be successful.
Affected products
- Adobe Acs Aem Commons: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: Adobe Acs Aem Commons 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/Adobe-Consulting-Services/acs-aem-commons/security/advisories/GHSA-w5m2-299g-rff5
- https://github.com/Adobe-Consulting-Services/acs-aem-commons/security/advisories/GHSA-w5m2-299g-rff5
Get alerted when CVE-2022-28820 or the next vulnerability affects your stack