What’s Vulnerable › Vulnerabilities
CVE-2022-2883
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-22 · updated 2026-06-17
- Weakness: CWE-434
Description
In affected versions of Octopus Deploy it is possible to upload a zipbomb file as a task which results in Denial of Service
Affected products
- Octopus Deploy Octopus Server: before 2022.3.11043; from 2022.4.0 before 2022.4.8401 — fixed in 2022.3.11043, 2022.4.8401
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.3.11043, 2022.4.8401. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2023/sa2023-02/
- https://advisories.octopus.com/post/2023/sa2023-02/
Get alerted when CVE-2022-2883 or the next vulnerability affects your stack