What’s Vulnerable › Vulnerabilities

CVE-2022-2884

Description

A vulnerability in GitLab CE/EE affecting all versions from 11.3.4 prior to 15.1.5, 15.2 to 15.2.3, 15.3 to 15.3 to 15.3.1 allows an an authenticated user to achieve remote code execution via the Import from GitHub API endpoint

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.1.5, 15.2.3, 15.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2884 or the next vulnerability affects your stack