What’s Vulnerable › Vulnerabilities
CVE-2022-2887: WP Server Health Stats < 1.7.0 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Server Health Stats WordPress plugin before 1.7.0 does not escape some of its settings, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Affected products
- WP Server Health Stats: before 1.7.0 — fixed in 1.7.0
How to fix
Upgrade to a fixed version: WP Server Health Stats 1.7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/237541d5-c1a5-44f2-8e5f-82457b8f9497
- https://wpscan.com/vulnerability/237541d5-c1a5-44f2-8e5f-82457b8f9497
Get alerted when CVE-2022-2887 or the next vulnerability affects your stack