What’s Vulnerable › Vulnerabilities
CVE-2022-2889: Use After Free in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-19 · updated 2026-06-17
- Weakness: CWE-416
Description
Use After Free in GitHub repository vim/vim prior to 9.0.0225.
Affected products
- Fedoraproject Fedora: 35
- vim/vim: before 9.0.0225 — fixed in 9.0.0225
How to fix
Upgrade to a fixed version: vim/vim 9.0.0225. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/91c7cbfe31bbef57d5fcf7d76989fc159f73ef15
- https://huntr.dev/bounties/d1ac9817-825d-49ce-b514-1d5b12b6bdaa
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/91c7cbfe31bbef57d5fcf7d76989fc159f73ef15
- https://huntr.dev/bounties/d1ac9817-825d-49ce-b514-1d5b12b6bdaa
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C72HDIMR3KTTAO7QGTXWUMPBNFUFIBRD/
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-2889 or the next vulnerability affects your stack