What’s Vulnerable › Vulnerabilities
CVE-2022-28893
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-11 · updated 2026-06-17
- Weakness: CWE-416
Description
The SUNRPC subsystem in the Linux kernel through 5.17.2 can call xs_xprt_free before ensuring that sockets are in the intended state.
Affected products
- Debian Linux: 11.0
- Linux kernel: from 5.1 before 5.4.196; from 5.5 before 5.10.117; from 5.11 before 5.15.41; from 5.16 before 5.16.20; from 5.17 before 5.17.3 — fixed in 5.10.117, 5.15.41, 5.16.20, 5.17.3, 5.4.196
- NetApp H300E Firmware: all versions
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500E Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- NetApp Hci Compute Node Firmware: all versions
- NetApp Solidfire, Enterprise Sds & Hci Storage Node: all versions
- NetApp Solidfire & Hci Management Node: all versions
How to fix
Upgrade to a fixed version: Linux kernel 5.10.117, 5.15.41, 5.16.20, 5.17.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/04/11/3
- http://www.openwall.com/lists/oss-security/2022/04/11/4
- http://www.openwall.com/lists/oss-security/2022/04/11/5
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1a3b1bba7c7a5eb8a11513cf88427cb9d77bc60a
- https://security.netapp.com/advisory/ntap-20220526-0002/
- https://www.debian.org/security/2022/dsa-5161
- http://www.openwall.com/lists/oss-security/2022/04/11/3
- http://www.openwall.com/lists/oss-security/2022/04/11/4
- http://www.openwall.com/lists/oss-security/2022/04/11/5
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=1a3b1bba7c7a5eb8a11513cf88427cb9d77bc60a
- https://security.netapp.com/advisory/ntap-20220526-0002/
- https://www.debian.org/security/2022/dsa-5161
Get alerted when CVE-2022-28893 or the next vulnerability affects your stack