What’s Vulnerable › Vulnerabilities
CVE-2022-2891: WP 2FA < 2.3.0 - Time-Based Side-Channel Attack
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-203
Description
The WP 2FA WordPress plugin before 2.3.0 uses comparison operators that don't mitigate time-based attacks, which could be abused to leak information about the authentication codes being compared.
Affected products
- WP 2FA: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: WP 2FA 2.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/301b3dce-2584-46ec-92ed-1c0626522120
- https://wpscan.com/vulnerability/301b3dce-2584-46ec-92ed-1c0626522120
Get alerted when CVE-2022-2891 or the next vulnerability affects your stack