What’s Vulnerable › Vulnerabilities
CVE-2022-28960
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-19 · updated 2026-06-17
- Weakness: CWE-116
Description
A PHP injection vulnerability in Spip before v3.2.8 allows attackers to execute arbitrary PHP code via the _oups parameter at /ecrire.
Affected products
- SPIP: before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: SPIP 3.2.8. Check the vendor advisory for mitigations.
References
- https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html
- https://github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4
- https://github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf
- https://thinkloveshare.com/en/hacking/rce_on_spip_and_root_me/
- https://www.root-me.org/fr/Informations/Faiblesses-decouvertes/
- https://blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-SPIP-3-2-8-et-SPIP-3-1-13.html
- https://github.com/spip/SPIP/commit/0394b44774555ae8331b6e65e35065dfa0bb41e4
- https://github.com/spip/SPIP/commit/6c1650713fc948318852ace759aab8f1a84791cf
- https://thinkloveshare.com/en/hacking/rce_on_spip_and_root_me/
- https://www.root-me.org/fr/Informations/Faiblesses-decouvertes/
Get alerted when CVE-2022-28960 or the next vulnerability affects your stack