What’s Vulnerable › Vulnerabilities
CVE-2022-28965
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-427
Description
Multiple DLL hijacking vulnerabilities via the components instup.exe and wsc_proxy.exe in Avast Premium Security before v21.11.2500 allows attackers to execute arbitrary code or cause a Denial of Service (DoS) via a crafted DLL file.
Affected products
- Avast Premium Security: before 21.11.2500 — fixed in 21.11.2500
How to fix
Upgrade to a fixed version: Avast Premium Security 21.11.2500. Check the vendor advisory for mitigations.
References
- https://forum.avast.com/index.php?topic=318305.0
- https://github.com/netero1010/Vulnerability-Disclosure/tree/main/CVE-2022-AVAST2
- https://forum.avast.com/index.php?topic=318305.0
- https://github.com/netero1010/Vulnerability-Disclosure/tree/main/CVE-2022-AVAST2
Get alerted when CVE-2022-28965 or the next vulnerability affects your stack