What’s Vulnerable › Vulnerabilities
CVE-2022-2901: Improper Authorization in chatwoot/chatwoot
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization in GitHub repository chatwoot/chatwoot prior to 2.8.
Affected products
- chatwoot/chatwoot: before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: chatwoot/chatwoot 2.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/chatwoot/chatwoot/commit/329e8c37c8ebc1b3629c0c3830b0e3070a3adc2a
- https://huntr.dev/bounties/cf46e0a6-f1b5-4959-a952-be9e4bac03fe
- https://github.com/chatwoot/chatwoot/commit/329e8c37c8ebc1b3629c0c3830b0e3070a3adc2a
- https://huntr.dev/bounties/cf46e0a6-f1b5-4959-a952-be9e4bac03fe
Get alerted when CVE-2022-2901 or the next vulnerability affects your stack