What’s Vulnerable › Vulnerabilities
CVE-2022-2903: NinjaForms < 3.6.13 - Admin+ PHP Objection Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-26 · updated 2026-06-17
- Weakness: CWE-502
Description
The Ninja Forms Contact Form WordPress plugin before 3.6.13 unserialises the content of an imported file, which could lead to PHP object injections issues when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.6.13 — fixed in 3.6.13
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.6.13. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/255b98ba-5da9-4424-a7e9-c438d8905864
- https://wpscan.com/vulnerability/255b98ba-5da9-4424-a7e9-c438d8905864
Get alerted when CVE-2022-2903 or the next vulnerability affects your stack