What’s Vulnerable › Vulnerabilities
CVE-2022-29030
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-680
Description
A vulnerability has been identified in JT2Go (All versions < V13.3.0.3), Teamcenter Visualization V13.3 (All versions < V13.3.0.3), Teamcenter Visualization V14.0 (All versions < V14.0.0.1). The Mono_Loader.dll library is vulnerable to integer overflow condition while parsing specially crafted TG4 files. An attacker could leverage this vulnerability to crash the application causing denial of service condition.
Affected products
- Siemens JT2Go: before 13.3.0.3 — fixed in 13.3.0.3
- Siemens Teamcenter Visualization: from 13.3 before 13.3.0.3; from 14.0 before 14.0.0.1 — fixed in 13.3.0.3, 14.0.0.1
How to fix
Upgrade to a fixed version: Siemens JT2Go 13.3.0.3; Siemens Teamcenter Visualization 13.3.0.3, 14.0.0.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-553086.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-553086.pdf
Get alerted when CVE-2022-29030 or the next vulnerability affects your stack