What’s Vulnerable › Vulnerabilities
CVE-2022-29036
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 71.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Affected products
- Jenkins project Jenkins Credentials Plugin: before 2.6.1.1; from 1055.v1346ba467ba1 before 1074.1076.v39c30cecb_0e2; from 1105.vb_4e24a_c78b_81 before 1112.vc87b_7a_3597f6 — fixed in 1074.1076.v39c30cecb_0e2, 1112.vc87b_7a_3597f6, 2.6.1.1
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Credentials Plugin 1074.1076.v39c30cecb_0e2, 1112.vc87b_7a_3597f6, 2.6.1.1. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617
Get alerted when CVE-2022-29036 or the next vulnerability affects your stack