What’s Vulnerable › Vulnerabilities

CVE-2022-2904

Description

A cross-site scripting issue has been discovered in GitLab CE/EE affecting all versions starting from 15.2 before 15.2.5, all versions starting from 15.3 before 15.3.4, all versions starting from 15.4 before 15.4.1 It was possible to exploit a vulnerability in the external status checks feature which could lead to a stored XSS that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.2.5, 15.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2904 or the next vulnerability affects your stack