What’s Vulnerable › Vulnerabilities
CVE-2022-29041
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Affected products
- Jenkins project Jenkins Jira Plugin: before 3.6.1; 3.7 — fixed in 3.6.1
How to fix
Upgrade to a fixed version: Jenkins project Jenkins Jira Plugin 3.6.1. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2617
Get alerted when CVE-2022-29041 or the next vulnerability affects your stack