What’s Vulnerable › Vulnerabilities
CVE-2022-29047
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Jenkins Pipeline: Shared Groovy Libraries Plugin 564.ve62a_4eb_b_e039 and earlier, except 2.21.3, allows attackers able to submit pull requests (or equivalent), but not able to commit directly to the configured SCM, to effectively change the Pipeline behavior by changing the definition of a dynamically retrieved library in their pull request, even if the Pipeline is configured to not trust them.
Affected products
- Jenkins Pipeline: Shared Groovy Libraries: before 2.21.3; from 544.vff04fa68714d before 566.vd0a_a_3334a_555 — fixed in 2.21.3, 566.vd0a_a_3334a_555
How to fix
Upgrade to a fixed version: Jenkins Pipeline: Shared Groovy Libraries 2.21.3, 566.vd0a_a_3334a_555. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-1951
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-1951
Get alerted when CVE-2022-29047 or the next vulnerability affects your stack