What’s Vulnerable › Vulnerabilities
CVE-2022-29055
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-18 · updated 2026-06-17
- Weakness: CWE-824
Description
A access of uninitialized pointer in Fortinet FortiOS version 7.2.0, 7.0.0 through 7.0.5, 6.4.0 through 6.4.8, 6.2.0 through 6.2.10, 6.0.x, FortiProxy version 7.0.0 through 7.0.4, 2.0.0 through 2.0.9, 1.2.x allows a remote unauthenticated or authenticated attacker to crash the sslvpn daemon via an HTTP GET request.
Affected products
- Fortinet FortiOS (FortiGate): from 6.2.0 before 6.2.11; from 6.4.0 before 6.4.10; from 7.0.0 before 7.0.7; 7.2.0 — fixed in 6.2.11, 6.4.10, 7.0.7
- Fortinet FortiProxy: from 1.2.6 before 1.2.13; from 2.0.0 before 2.0.10; from 7.0.0 before 7.0.7; 7.2.0 — fixed in 1.2.13, 2.0.10, 7.0.7
How to fix
Upgrade to a fixed version: Fortinet FortiOS (FortiGate) 6.2.11, 6.4.10, 7.0.7; Fortinet FortiProxy 1.2.13, 2.0.10, 7.0.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-29055 or the next vulnerability affects your stack