What’s Vulnerable › Vulnerabilities
CVE-2022-29058
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-06 · updated 2026-06-17
- Weakness: CWE-89
Description
An improper neutralization of special elements [CWE-89] used in an OS command vulnerability [CWE-78] in the command line interpreter of FortiAP 6.0.0 through 6.4.7, 7.0.0 through 7.0.3, 7.2.0, FortiAP-S 6.0.0 through 6.4.7, FortiAP-W2 6.0.0 through 6.4.7, 7.0.0 through 7.0.3, 7.2.0 and FortiAP-U 5.4.0 through 6.2.3 may allow an authenticated attacker to execute unauthorized commands via specifically crafted arguments to existing commands.
Affected products
- Fortinet FortiAP: from 6.0.0 through 6.0.6; from 6.4.3 before 6.4.8; from 7.0.0 before 7.0.4; 7.2.0 — fixed in 6.4.8, 7.0.4
- Fortinet FortiAP-S: from 6.0.0 through 6.0.6; from 6.2.0 through 6.2.6; from 6.4.0 before 6.4.8 — fixed in 6.4.8
- Fortinet FortiAP-U: from 5.4.0 through 5.4.6; from 6.0.0 through 6.0.4; from 6.2.0 before 6.2.4 — fixed in 6.2.4
- Fortinet FortiAP-W2: from 6.0.0 through 6.0.6; from 6.2.0 through 6.2.6; from 6.4.0 before 6.4.8; from 7.0.0 before 7.0.4; 7.2.0 — fixed in 6.4.8, 7.0.4
How to fix
Upgrade to a fixed version: Fortinet FortiAP 6.4.8, 7.0.4; Fortinet FortiAP-S 6.4.8; Fortinet FortiAP-U 6.2.4; Fortinet FortiAP-W2 6.4.8, 7.0.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-29058 or the next vulnerability affects your stack