What’s Vulnerable › Vulnerabilities
CVE-2022-29059
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-14 · updated 2026-06-17
- Weakness: CWE-89
Description
An improper neutralization of special elements used in an SQL command ('SQL Injection') vulnerability [CWE-89] in FortiWeb version 7.0.1 and below, 6.4.2 and below, 6.3.20 and below, 6.2.7 and below may allow a privileged attacker to execute SQL commands over the log database via specifically crafted strings parameters.
Affected products
- Fortinet FortiWeb: from 6.2.3 through 6.2.7; from 6.3.0 through 6.3.18; from 6.4.0 through 6.4.2; from 7.0.0 before 7.0.2 — fixed in 7.0.2
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-29059 or the next vulnerability affects your stack