What’s Vulnerable › Vulnerabilities
CVE-2022-29077
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-04-25 · updated 2026-06-17
- Weakness: CWE-787
Description
A heap-based buffer overflow exists in rippled before 1.8.5. The vulnerability allows attackers to cause a crash or execute commands remotely on a rippled node, which may lead to XRPL mainnet DoS or compromise. This exposes all digital assets on the XRPL to a security threat.
Affected products
- Rippled: before 1.8.5 — fixed in 1.8.5
How to fix
Upgrade to a fixed version: Rippled 1.8.5. Check the vendor advisory for mitigations.
References
- https://github.com/ripple/rippled/compare/1.8.4...1.8.5
- https://ripple.com/
- https://xrpl.org/blog/2022/rippled-1.8.5.html
- https://github.com/ripple/rippled/compare/1.8.4...1.8.5
- https://ripple.com/
- https://xrpl.org/blog/2022/rippled-1.8.5.html
Get alerted when CVE-2022-29077 or the next vulnerability affects your stack