What’s Vulnerable › Vulnerabilities

CVE-2022-2908

Description

A potential DoS vulnerability was discovered in Gitlab CE/EE versions starting from 10.7 before 15.1.5, all versions starting from 15.2 before 15.2.3, all versions starting from 15.3 before 15.3.1 allowed an attacker to trigger high CPU usage via a special crafted input added in the Commit message field.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.1.5, 15.2.3, 15.3.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-2908 or the next vulnerability affects your stack