What’s Vulnerable › Vulnerabilities
CVE-2022-29089
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-28 · updated 2026-06-17
- Weakness: CWE-522
Description
Dell Networking OS10, versions prior to October 2021 with Smart Fabric Services enabled, contains an information disclosure vulnerability. A remote, unauthenticated attacker could potentially exploit this vulnerability by reverse engineering to retrieve sensitive information and access the REST API with admin privileges.
Affected products
- Dell SmartFabric OS10 Software: from 10.5.1.0 before 10.5.1.11; from 10.5.2.0 before 10.5.2.11; from 10.5.3.0 before 10.5.3.5 — fixed in 10.5.1.11, 10.5.2.11, 10.5.3.5
How to fix
Upgrade to a fixed version: Dell SmartFabric OS10 Software 10.5.1.11, 10.5.2.11, 10.5.3.5. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000202971/dsa-2022-135-dell-emc-smartfabric-os10-security-update-for-multiple-security-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000202971/dsa-2022-135-dell-emc-smartfabric-os10-security-update-for-multiple-security-vulnerabilities
Get alerted when CVE-2022-29089 or the next vulnerability affects your stack