What’s Vulnerable › Vulnerabilities
CVE-2022-29155
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 64.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-04 · updated 2026-10-14
- Weakness: CWE-89
Description
In OpenLDAP 2.x before 2.5.12 and 2.6.x before 2.6.2, a SQL injection vulnerability exists in the experimental back-sql backend to slapd, via a SQL statement within an LDAP query. This can occur during an LDAP search operation when the search filter is processed, due to a lack of proper escaping.
Affected products
- Debian Linux: 9.0, 10.0, 11.0
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700E Firmware: all versions
- NetApp H700S Firmware: all versions
- openldap: from 2.0 before 2.5.12; from 2.6.0 before 2.6.2 — fixed in 2.5.12, 2.6.2
How to fix
Upgrade to a fixed version: openldap 2.5.12, 2.6.2. Check the vendor advisory for mitigations.
References
- https://bugs.openldap.org/show_bug.cgi?id=9815
- https://lists.debian.org/debian-lts-announce/2022/05/msg00032.html
- https://security.netapp.com/advisory/ntap-20220609-0007/
- https://www.debian.org/security/2022/dsa-5140
- https://bugs.openldap.org/show_bug.cgi?id=9815
- https://lists.debian.org/debian-lts-announce/2022/05/msg00032.html
- https://security.netapp.com/advisory/ntap-20220609-0007/
- https://www.debian.org/security/2022/dsa-5140
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
Get alerted when CVE-2022-29155 or the next vulnerability affects your stack