What’s Vulnerable › Vulnerabilities
CVE-2022-29158: Regular Expression Denial of Service (ReDoS) vulnerability in Apache OFBiz
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-02 · updated 2026-06-17
- Weakness: CWE-1333
Description
Apache OFBiz up to version 18.12.05 is vulnerable to Regular Expression Denial of Service (ReDoS) in the way it handles URLs provided by external, unauthenticated users. Upgrade to 18.12.06 or apply patches at https://issues.apache.org/jira/browse/OFBIZ-12599
Affected products
- Apache Software Foundation Apache OFBiz: before 18.12.06 — fixed in 18.12.06
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache OFBiz 18.12.06. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/09/02/5
- https://lists.apache.org/thread/7k92rg1o4ql2yw3o0vttkcl2jhq7j928
- http://www.openwall.com/lists/oss-security/2022/09/02/5
- https://lists.apache.org/thread/7k92rg1o4ql2yw3o0vttkcl2jhq7j928
Get alerted when CVE-2022-29158 or the next vulnerability affects your stack