What’s Vulnerable › Vulnerabilities
CVE-2022-29178: Incorrect Default Permissions in Cilium
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-276
Description
Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Cilium prior to versions 1.9.16, 1.10.11, and 1.11.15 contains an incorrect default permissions vulnerability. Operating Systems with users belonging to the group ID 1000 can access the API of Cilium via Unix domain socket available on the host where Cilium is running. This could allow malicious users to compromise integrity as well as system availability on that host. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. A potential workaround is to modify Cilium's DaemonSet to run with a certain command, which can be found in the GitHub Security Advisory for this vulnerability.
Affected products
- cilium: before 1.9.16; from 1.10.0 before 1.10.11; from 1.11.0 before 1.11.5 — fixed in 1.10.11, 1.11.5, 1.9.16
How to fix
Upgrade to a fixed version: cilium 1.10.11, 1.11.5, 1.9.16. Check the vendor advisory for mitigations.
References
- https://github.com/cilium/cilium/releases/tag/v1.10.11
- https://github.com/cilium/cilium/releases/tag/v1.11.5
- https://github.com/cilium/cilium/releases/tag/v1.9.16
- https://github.com/cilium/cilium/security/advisories/GHSA-6p8v-8cq8-v2r3
- https://github.com/cilium/cilium/releases/tag/v1.10.11
- https://github.com/cilium/cilium/releases/tag/v1.11.5
- https://github.com/cilium/cilium/releases/tag/v1.9.16
- https://github.com/cilium/cilium/security/advisories/GHSA-6p8v-8cq8-v2r3
Get alerted when CVE-2022-29178 or the next vulnerability affects your stack