What’s Vulnerable › Vulnerabilities
CVE-2022-29179: Improper Privilege Management in Cilium
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-269
Description
Cilium is open source software for providing and securing network connectivity and loadbalancing between application workloads. Prior to versions 1.9.16, 1.10.11, and 1.11.15, if an attacker is able to perform a container escape of a container running as root on a host where Cilium is installed, the attacker can escalate privileges to cluster admin by using Cilium's Kubernetes service account. The problem has been fixed and the patch is available in versions 1.9.16, 1.10.11, and 1.11.5. There are no known workarounds available.
Affected products
- cilium: before 1.9.16; from 1.10.0 before 1.10.11; from 1.11.0 before 1.11.5 — fixed in 1.10.11, 1.11.5, 1.9.16
How to fix
Upgrade to a fixed version: cilium 1.10.11, 1.11.5, 1.9.16. Check the vendor advisory for mitigations.
References
- https://github.com/cilium/cilium/releases/tag/v1.10.11
- https://github.com/cilium/cilium/releases/tag/v1.11.5
- https://github.com/cilium/cilium/releases/tag/v1.9.16
- https://github.com/cilium/cilium/security/advisories/GHSA-fmrf-gvjp-5j5g
- https://github.com/cilium/cilium/releases/tag/v1.10.11
- https://github.com/cilium/cilium/releases/tag/v1.11.5
- https://github.com/cilium/cilium/releases/tag/v1.9.16
- https://github.com/cilium/cilium/security/advisories/GHSA-fmrf-gvjp-5j5g
Get alerted when CVE-2022-29179 or the next vulnerability affects your stack