What’s Vulnerable › Vulnerabilities
CVE-2022-29183: Reflected XSS in GoCD
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-20 · updated 2026-06-17
- Weakness: CWE-79
Description
GoCD is a continuous delivery server. GoCD versions 20.2.0 until 21.4.0 are vulnerable to reflected cross-site scripting via abuse of the pipeline comparison function's error handling to render arbitrary HTML into the returned page. This could allow an attacker to trick a victim into executing code which would allow the attacker to operate on, or gain control over the same resources as the victim had access to. This issue is fixed in GoCD 21.4.0. As a workaround, block access to `/go/compare/.*` prior to GoCD Server via a reverse proxy, web application firewall or equivalent, which would prevent use of the pipeline comparison function.
Affected products
- gocd: from 20.2.0 before 21.4.0 — fixed in 21.4.0
How to fix
Upgrade to a fixed version: gocd 21.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/gocd/gocd/pull/9829/commits/bda81084c0401234b168437cf35a63390e3064d1
- https://github.com/gocd/gocd/releases/tag/21.4.0
- https://github.com/gocd/gocd/security/advisories/GHSA-3vvq-q4qv-x2gf
- https://www.gocd.org/releases/#21-4-0
- https://github.com/gocd/gocd/pull/9829/commits/bda81084c0401234b168437cf35a63390e3064d1
- https://github.com/gocd/gocd/releases/tag/21.4.0
- https://github.com/gocd/gocd/security/advisories/GHSA-3vvq-q4qv-x2gf
- https://www.gocd.org/releases/#21-4-0
Get alerted when CVE-2022-29183 or the next vulnerability affects your stack