What’s Vulnerable › Vulnerabilities
CVE-2022-29187: Bypass of safe.directory protections in Git
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-282
Description
Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all platforms. An unsuspecting user could still be affected by the issue reported in CVE-2022-24765, for example when navigating as root into a shared tmp directory that is owned by them, but where an attacker could create a git repository. Versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5 contain a patch for this issue. The simplest way to avoid being affected by the exploit described in the example is to avoid running git as root (or an Administrator in Windows), and if needed to reduce its use to a minimum. While a generic workaround is not possible, a system could be hardened from the exploit described in the example by removing any such repository if it exists already and creating one as root to block any future attacks.
Affected products
- Apple Xcode: before 14.1 — fixed in 14.1
- Debian Linux: 10.0
- Fedoraproject Fedora: 35, 36, 37
- git: from 2.30.3 before 2.30.5; from 2.31.2 before 2.31.4; from 2.32.1 before 2.32.3; from 2.33.2 before 2.33.4; from 2.34.2 before 2.34.4; from 2.35.2 before 2.35.4 — fixed in 2.30.5, 2.31.4, 2.32.3, 2.33.4, 2.34.4, 2.35.4
How to fix
Upgrade to a fixed version: Apple Xcode 14.1; git 2.30.5, 2.31.4, 2.32.3, 2.33.4. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2022/Nov/1
- http://www.openwall.com/lists/oss-security/2022/07/14/1
- https://github.blog/2022-04-12-git-security-vulnerability-announced
- https://github.com/git/git/security/advisories/GHSA-j342-m5hw-rr3v
- https://lists.debian.org/debian-lts-announce/2022/12/msg00025.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DDI325LOO2XBDDKLINOAQJEG6MHAURZE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DIKWISWUDFT2FAITYIA6372BVLH3OOOC/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HVOLER2PIGMHPQMDGG4RDE2KZB74QLA2/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TRZG5CDUQ27OWTPC5MQOR4UASNXHWEZS/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UDZRZAL7QULOB6V7MKT66MOMWJLBJPX4/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YROCMBWYFKRSS64PO6FUNM6L7LKBUKVW/
- https://lore.kernel.org/git/xmqqv8s2fefi.fsf%40gitster.g/T/#u
Get alerted when CVE-2022-29187 or the next vulnerability affects your stack