What’s Vulnerable › Vulnerabilities

CVE-2022-29198: Missing validation causes denial of service in TensorFlow via `SparseTensorToCSRSparseMatrix`

Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.raw_ops.SparseTensorToCSRSparseMatrix` does not fully validate the input arguments. This results in a `CHECK`-failure which can be used to trigger a denial of service attack. The code assumes `dense_shape` is a vector and `indices` is a matrix (as part of requirements for sparse tensors) but there is no validation for this. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Affected products

How to fix

Upgrade to a fixed version: tensorflow 2.6.4, 2.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-29198 or the next vulnerability affects your stack