What’s Vulnerable › Vulnerabilities

CVE-2022-29202: Denial of service in TensorFlow due to lack of validation in `tf.ragged.constant`

Description

TensorFlow is an open source platform for machine learning. Prior to versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4, the implementation of `tf.ragged.constant` does not fully validate the input arguments. This results in a denial of service by consuming all available memory. Versions 2.9.0, 2.8.1, 2.7.2, and 2.6.4 contain a patch for this issue.

Affected products

How to fix

Upgrade to a fixed version: tensorflow 2.6.4, 2.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-29202 or the next vulnerability affects your stack