What’s Vulnerable › Vulnerabilities
CVE-2022-29214: URL Redirection to Untrusted Site ('Open Redirect') in next-auth
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-21 · updated 2026-06-17
- Weakness: CWE-601
Description
NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. Prior to versions 3.29.3 and 4.3.3, an open redirect vulnerability is present when the developer is implementing an OAuth 1 provider. Versions 3.29.3 and 4.3.3 contain a patch for this issue. The maintainers recommend adding a certain configuration to one's `callbacks` option as a workaround for those unable to upgrade.
Affected products
- nextauthjs next-auth: before 3.29.3; from 4.0.0 before 4.3.3 — fixed in 3.29.3, 4.3.3
How to fix
Upgrade to a fixed version: nextauthjs next-auth 3.29.3, 4.3.3. Check the vendor advisory for mitigations.
References
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%40v4.3.3
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-q2mx-j4x2-2h74
- https://github.com/nextauthjs/next-auth/releases/tag/next-auth%40v4.3.3
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-q2mx-j4x2-2h74
Get alerted when CVE-2022-29214 or the next vulnerability affects your stack