What’s Vulnerable › Vulnerabilities
CVE-2022-29215: Argument Injection in RegionProtect
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-05-21 · updated 2026-06-17
- Weakness: CWE-88
Description
RegionProtect is a plugin that allows users to manage certain events in certain regions of the world. Versions prior to 1.1.0 contain a YAML injection vulnerability that can cause an instant server crash if the passed arguments are not matched. Version 1.1.0 contains a patch for this issue. As a workaround, restrict operator permissions to untrusted people and avoid entering arguments likely to cause a crash.
Affected products
- kaidomc-pm-pl RegionProtect: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: kaidomc-pm-pl RegionProtect 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/kaidomc-pm-pl/RegionProtect/commit/0060d421358ab59acb6a168eab0d11c43d2d105d
- https://github.com/kaidomc-pm-pl/RegionProtect/security/advisories/GHSA-7gr2-w2r3-r9vf
- https://github.com/kaidomc-pm-pl/RegionProtect/commit/0060d421358ab59acb6a168eab0d11c43d2d105d
- https://github.com/kaidomc-pm-pl/RegionProtect/security/advisories/GHSA-7gr2-w2r3-r9vf
Get alerted when CVE-2022-29215 or the next vulnerability affects your stack